weekly-changelog-report.py: add staging-branch
[openembedded.git] / recipes / cpio / cpio_2.5.bb
blob5c4ee632d74b136154f71342b8d478e510e719c3
1 DESCRIPTION = "GNU cpio is a program to manage archives of files."
2 HOMEPAGE = "http://www.gnu.org/software/cpio/"
3 SECTION = "console"
4 LICENSE = "GPL"
5 PR = "r5"
7 DEPENDS += " texinfo-native "
9 SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://install.patch;patch=1"
11 S = "${WORKDIR}/cpio-${PV}"
13 inherit autotools
15 do_install () {
16 autotools_do_install
17 install -d ${D}${base_bindir}/
18 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio.${PN}"
19 case ${TARGET_OS} in
20 *-uclibc*) ;;
21 *) mv "${D}${libexecdir}/rmt" "${D}${libexecdir}/rmt.${PN}" ;;
22 esac
25 pkg_postinst_${PN} () {
26 update-alternatives --install ${base_bindir}/cpio cpio cpio.${PN} 100
27 if [ -f ${libexecdir}/rmt.${PN} ]
28 then
29 update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 50
33 pkg_prerm_${PN} () {
34 update-alternatives --remove cpio cpio.${PN}
35 if [ -f ${libexecdir}/rmt.${PN} ]
36 then
37 update-alternatives --remove rmt rmt.${PN}