weekly-changelog-report.py: add staging-branch
[openembedded.git] / recipes / blackbox / blackbox_0.70.1.bb
blob0376f9998041ccb59a891498e55b22ea01a321d2
1 DESCRIPTION = "Blackbox Window Manager"
2 SECTION = "x11/wm"
3 LICENSE = "GPL"
4 DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft"
5 PR = "r1"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/blackboxwm/blackbox-0.70.1.tar.gz \
8 file://remove-host-includes.patch;patch=1"
9 S = "${WORKDIR}/blackbox-${PV}"
11 inherit autotools pkgconfig
13 EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
15 #fix path of pc file
16 do_install_append() {
17 sed -i s#${STAGING_LIBDIR}#${libdir}#g ${D}/${libdir}/pkgconfig/libbt.pc
20 do_stage () {
21 sed -i s#${STAGING_LIBDIR}#${libdir}#g ${STAGING_LIBDIR}/pkgconfig/libbt.pc