libdrm: drop older versions
[openembedded.git] / recipes / nautilus / nautilus_2.30.0.bb
blobda6c8f81ebcde416070cfab4aa1da3768ac8fede
1 # nautilus OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 inherit gnome
7 SRC_URI += "file://idl-sysroot.patch \
8 file://no-try-run-strftime.diff \
11 SRC_URI[archive.md5sum] = "e09aea66166c0a90d09955bd4d2672be"
12 SRC_URI[archive.sha256sum] = "01ecbc4b8b9a0ac726194eb81d3de7080ee52d885eb1898692aa951b093731a5"
14 export SYSROOT = "${STAGING_DIR_HOST}"
16 LICENSE="GPL"
18 DEPENDS += "libunique gvfs tracker librsvg libexif esound gnome-desktop orbit2-native"
19 RDEPENDS_${PN} = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
20 PR = "r1"
22 EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
24 PACKAGES += " libnautilus"
26 FILES_${PN} += "${datadir}/icons /usr/libexec/ "
27 FILES_libnautilus = "/usr/lib/*.so*"
28 FILES_${PN}-dbg += "/usr/libexec/.debug"
30 do_configure_prepend() {
31 sed -i -e /docs/d Makefile.am
34 # We need native orbit-idl with target idl files. No way to say it in a clean way:
35 do_configure_append () {
36 find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;