libdrm: drop older versions
[openembedded.git] / recipes / libowl / libowl_svn.bb
blobfa1254f50f5a6c6b8d35bd7b12caf153eef6210c
1 # This recipe builds libowl and then stages the header and static lib;
2 # it intentionally does not stage the shared lib and create a package.
4 # Libowl is currently a 'cut and paste' library; this package makes our
5 # life a touch easier by not having to patch the source directly into
6 # applications; instead we add -lowl to the linker cmdline. Also, when
7 # we eventually make libowl into a normal shared library, this package
8 # will make that transition rather simple.
10 DESCRIPTION = "OpenedHand Widget Library"
11 HOMEPAGE = "http://www.o-hand.com"
12 LICENSE = "LGPL"
13 SECTION = "libs"
14 DEPENDS = "gtk+"
15 SRCREV = "277"
16 PV = "0.0+svnr${SRCPV}"
17 PR = "r3"
19 PACKAGES = ""
21 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
23 S = "${WORKDIR}/${PN}"
25 inherit autotools pkgconfig
27 do_compile_prepend() {
28 # have to unstage the library first so that the tests build
29 rm -f ${STAGING_LIBDIR}/libowl*
30 rm -f ${STAGING_INCDIR}/owl*
33 do_stage() {
34 headers=`eval ls libowl/owl*.h`
35 for header in $headers; do
36 hdr_base=`eval basename $header`
37 install -m 644 $header ${STAGING_INCDIR}/$hdr_base
38 done
39 install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/