angstrom-uboot-scripts: Change installdir to /boot and rename configs
[openembedded.git] / recipes / angstrom / angstrom-uboot-scripts.bb
blob67245a05062cd1910e645b4d2b40af38a19ad88d
1 DESCRIPTION = "Various uboot scripts"
3 PR = "r1"
5 DEPENDS = "u-boot-mkimage-native"
7 SRC_URI = "file://*.cmd"
9 do_configure() {
10 cp ${WORKDIR}/*.cmd ${S}
12 for i in *.cmd ; do
13 mv $i uboot-$i
14 done
17 do_compile() {
18 for i in *.cmd ; do
19 uboot-mkimage -A ${TARGET_ARCH} -O linux -T script -C none -a 0 -e 0 -n "Angstrom $i" -d $i $i.scr
20 done
23 do_install() {
24 install -d ${D}/boot/u-boot-scripts
25 for i in *.cmd *.scr ; do
26 install -m 0644 $i ${D}/boot/u-boot-scripts
27 done
30 FILES_${PN} += "/boot"
32 addtask deploy before do_package after do_install
34 do_deploy() {
35 install -d ${DEPLOY_DIR_IMAGE}
36 for i in *.scr ; do
37 cp $i ${DEPLOY_DIR_IMAGE}
38 package_stagefile_shell ${DEPLOY_DIR_IMAGE}/$i
39 done
42 PACKAGE_ARCH = "${MACHINE_ARCH}"