libtool-sdk: Convert from legacy staging
[openembedded.git] / recipes / w3cam / w3cam_0.7.2.bb
blob5ec857b87bb978236eda217f2ab517c9ab99374a
1 DESCRIPTION = "a small and fast cgi program to retrieve images from a V4L device."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 DEPENDS="jpeg"
5 LICENSE = "GPLV2"
6 PR = "r0"
8 SRC_URI = "http://mpx.freeshell.net/w3cam-0.7.2.tar.gz \
9 file://staticpaths.patch"
11 S = "${WORKDIR}/w3cam-0.7.2/"
13 inherit autotools
15 LDFLAGS += "-L${STAGING_LIBDIR}"
16 CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
18 EXTRA_OECONF = "--without-x --without-ttf-inc"
20 do_install() {
21 install -d ${D}${sbindir}
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24 install -d ${D}usr/cgi-bin
25 install -m 0755 ${S}w3camd/w3camd ${D}${sbindir}/w3camd
26 install -m 0755 ${S}w3cam.cgi ${D}usr/cgi-bin/w3camd.cgi
27 install -m 0755 ${S}vidcat ${D}${bindir}/vidcat
28 install -m 0644 ${S}vidcat.1 ${D}${mandir}/man1/vidcat.1
32 SRC_URI[md5sum] = "eec0b301b32bc8e9f65a4e54248c9868"
33 SRC_URI[sha256sum] = "96d659d916fafe555311068c9bf8662b93f10d099b12b17ed04d8a8fffbc72e0"