8 staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
9 for majmin in "2.6 2.5 2.4 2.3".split():
10 if os.path.exists( "%s/python%s" % ( staging_incdir, majmin ) ): return "python%s" % majmin
11 if not "python-native" in bb.data.getVar( "DEPENDS", d, 1 ).split():
12 raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
15 PYTHON_DIR = "${@python_dir(d)}"
17 PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc ${PN}"
19 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
22 ${datadir}/pkgconfig \
24 ${libdir}/${PYTHON_DIR}/site-packages/*.la \
27 ${libdir}/${PYTHON_DIR}/site-packages/.debug \
28 ${libdir}/${PYTHON_DIR}/site-packages/*/.debug \
29 ${libdir}/${PYTHON_DIR}/site-packages/*/*/.debug \