libtool-cross 2.2.6[ab]: Drop legacy staging, taken from poky
[openembedded.git] / recipes / openntpd / openntpd_3.9p1.bb
blob3ed2a0fd05134737043fad7b0115bbb772bece4f
1 DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
2 Network Time Protocol."
3 HOMEPAGE = "http://www.openntpd.org/"
4 SECTION = "console/network"
5 LICENSE = "BSD"
6 DEPENDS += "openssl tzdata"
7 PR = "r1"
9 SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/${P}.tar.gz \
10 file://adjtimex-${PV}.patch \
11 file://init"
13 S = "${WORKDIR}/openntpd-${PV}"
15 inherit autotools update-rc.d
17 EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
18 --sysconfdir=/etc --with-privsep-path=/${localstatedir}/shared/empty \
19 --with-privsep-user=ntpd \
20 --with-builtin-arc4random \
21 --without-ssl-dir"
23 do_install_prepend() {
24 install -d ${D}${sysconfdir}/init.d
26 do_install_append() {
27 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
30 pkg_postinst () {
31 [ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
32 grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
33 chown root:root ${localstatedir}/shared/empty
36 pkg_postrm () {
37 grep ntpd ${sysconfdir}/passwd && deluser ntpd
40 INITSCRIPT_NAME = "openntpd"
42 INITSCRIPT_PARAMS = "defaults"
44 SRC_URI[md5sum] = "afc34175f38d08867c1403d9008600b3"
45 SRC_URI[sha256sum] = "83dd7c1e8ec8b4567afe49af539271b5a73562fb7a3ca51df73eccba89ec8c49"