libtool-cross 2.2.6[ab]: Drop legacy staging, taken from poky
[openembedded.git] / recipes / openntpd / openntpd_3.7p1.bb
blobf1bf431c6e5f5291052dfe7f657dcb7e9ab076fe
1 DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
2 Network Time Protocol."
3 HOMEPAGE = "http://www.openntpd.org/"
4 SECTION = "console/network"
5 LICENSE = "BSD"
6 DEPENDS += "openssl tzdata"
7 PR = "r14"
9 SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
10 file://autofoo.patch \
11 file://adjtimex-${PV}.patch \
12 file://makefile-install.patch \
13 file://init"
15 S = "${WORKDIR}/openntpd-${PV}"
17 inherit autotools update-rc.d
19 EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
20 --sysconfdir=/etc --with-privsep-path=/${localstatedir}/shared/empty \
21 --with-privsep-user=ntpd \
22 --with-builtin-arc4random \
23 --without-ssl-dir"
25 do_install_prepend() {
26 install -d ${D}${sysconfdir}/init.d
28 do_install_append() {
29 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
32 pkg_postinst () {
33 [ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
34 grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
35 chown root:root ${localstatedir}/shared/empty
38 pkg_postrm () {
39 grep ntpd ${sysconfdir}/passwd && deluser ntpd
42 INITSCRIPT_NAME = "openntpd"
44 INITSCRIPT_PARAMS = "defaults"
46 SRC_URI[md5sum] = "10ed8eefd760e5819efcf3277b118f47"
47 SRC_URI[sha256sum] = "313509a7ccb15565e911f61c599055afc705cfe4bf6370bdc1c30582d52a9ea9"