libtool-cross 2.2.6[ab]: Drop legacy staging, taken from poky
[openembedded.git] / recipes / openal / openal_0.0.8.bb
blob79da60e1512d161137da815bf49ac761b80a8cb2
1 DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
2 DEPENDS = "alsa-lib virtual/libsdl libvorbis"
4 SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
5 file://void-workaround.patch"
7 inherit autotools pkgconfig
9 EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
10 --disable-smpeg --disable-arts"
12 do_configure_append () {
13 sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
16 PACKAGES =+ "libopenal"
18 FILES_libopenal += "${libdir}/libopenal.so.*"
19 FILES_openal-dev += "${bindir}/openal-config"
20 FILES_openal = ""
22 SRC_URI[md5sum] = "641cf53761f35ee979f3e888614797a0"
23 SRC_URI[sha256sum] = "723e2c57c3cdffa7ff11f9b6b5478d6cb4af017e5a1ee7a56032969c39c1c2fe"
24 #CHECKSUMS.INI MISMATCH: I've got this instead:
25 #SRC_URI[md5sum] = "0379bd39fc84454491ef38434a2e6e8d"
26 #SRC_URI[sha256sum] = "5eb6f111539d1a22030dc36f10ad20fed94148a66d71885265e8f1b931db4538"