libtool-cross 2.2.6[ab]: Drop legacy staging, taken from poky
[openembedded.git] / recipes / cdstatus / cdstatus_0.97.01.bb
blob58576f48e40e1ad911031d5640169ab00314aaf8
1 # cdstatus OE build file
3 PR ="r0"
4 LICENSE="GPL"
5 HOMEPAGE = "http://cdstatus.sourceforge.net/"
6 FILES_${PN} += "${datadir}/cdstatus.cfg"
7 # need __USE_MISC to get h_addr macro in netdb.h
8 CFLAGS += -D__USE_MISC
10 SRC_URI="${SOURCEFORGE_MIRROR}/cdstatus/cdstatus-0.97.01.tar.gz \
11 file://Makefile.am.patch \
12 file://cddb_connect_to_server.c.patch \
13 file://cdstatus.patch"
15 S="${WORKDIR}/cdstatus-0.97.01"
17 inherit autotools
19 do_install() {
20 install -d 0755 ${D}/${bindir}
21 install -d 0755 ${D}/${datadir}
22 install -d 0755 ${D}/${mandir}
23 install -m 0755 src/cdstatus ${D}/${bindir}
24 install -m 0644 cdstatus.cfg ${D}/${datadir}
25 install -m 0644 cdstatus.1 ${D}/${mandir}
28 SRC_URI[md5sum] = "e53d3f8759251603c980b38982a85f1e"
29 SRC_URI[sha256sum] = "548b5b402ee5fff34fe428eb69de560b56709337cd70c600ad21686c1321dd66"