linux-omap 2.6.39: sync with meta-texasinstruments
[openembedded.git] / recipes / wpa-supplicant / wpa-gui_0.6.9.bb
blob386fd88ebf8cc7054b1f8f197ddab07297dc9e5c
1 DESCRIPTION = "Qt interface for choosing which configured network to connect \
2 to. It also provides a method for browsing 802.11 SSID scan results, an event \
3 history log of messages generated by wpa_supplicant, and a method to add or \
4 edit wpa_supplicant networks."
5 SECTION = "network"
6 LICENSE = "GPL BSD"
7 HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
8 DEPENDS = "librsvg-native imagemagick-native"
9 RDEPENDS_${PN} = "wpa-supplicant"
10 RRECOMMENDS_${PN} = "${LIBC}-gconv-utf-16"
11 PR = "r3"
13 SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz;name=archive\
14 file://icons.patch \
15 file://session_manager.patch "
17 SRC_URI_append_shr = "file://desktop.patch \
18 file://style"
20 S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_supplicant/wpa_gui-qt4"
22 inherit qt4x11
23 ARM_INSTRUCTION_SET = "arm"
25 do_compile_append() {
26 oe_runmake -C ${S}/icons
29 do_install () {
30 install -d ${D}${bindir}
31 install -d ${D}${datadir}/wpa_gui
32 install -d ${D}${datadir}/applications
33 install -d ${D}${datadir}/pixmaps
34 install -m 644 icons/hicolor/128x128/apps/wpa_gui.png ${D}${datadir}/pixmaps
35 install -m 755 wpa_gui ${D}/${bindir}
36 install -m 644 wpa_gui.desktop ${D}/${datadir}/applications
39 do_install_append_shr() {
40 install -m 644 ${WORKDIR}/style ${D}/${datadir}/wpa_gui
43 FILES_${PN} = "/usr/share/pixmaps/wpa_gui.png \
44 /usr/share/wpa_gui/style \
45 /usr/bin/wpa_gui \
46 /usr/share/applications/wpa_gui.desktop"
48 FILES_${PN}_append_shr = " /usr/share/wpa_gui/style"
50 SRC_URI[archive.md5sum] = "0efb8fcedf0a8acf6f423dfdb0658fdd"
51 SRC_URI[archive.sha256sum] = "6e5284fa3f7c56e001fae92486eaa31340db5dd925dcb38bd572d2e8ed70f570"