linux-omap 2.6.39: sync with meta-texasinstruments
[openembedded.git] / recipes / mamona / gcc-noemu_4.1.2.bb
blob78c7d799a3a18a097050a1b920e5c16157e14327
1 DESCRIPTION = "The GNU cc and gcc C compilers."
2 HOMEPAGE = "http://www.gnu.org/software/gcc/"
3 SECTION = "devel"
4 LICENSE = "GPL"
5 # NOTE: split PR. If the main .bb changes something that affects its *build*
6 # remember to increment the -cross .bb PR too.
7 PR = "r1"
9 RCONFLICTS_${PN} = "gcc"
10 RREPLACES_${PN} = "gcc"
11 RCONFLICTS_g++-noemu = "g++"
12 RREPLACES_g++-noemu = "g++"
13 RCONFLICTS_cpp-noemu = "cpp"
14 RREPLACES_cpp-noemu = "cpp"
16 inherit autotools gettext
18 require gcc-package-noemu.inc
20 SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
21 file://100-uclibc-conf.patch \
22 file://110-arm-eabi.patch \
23 file://200-uclibc-locale.patch \
24 file://300-libstdc++-pic.patch \
25 file://301-missing-execinfo_h.patch \
26 file://302-c99-snprintf.patch \
27 file://303-c99-complex-ugly-hack.patch \
28 file://304-index_macro.patch \
29 file://602-sdk-libstdc++-includes.patch \
30 file://740-sh-pr24836.patch \
31 file://800-arm-bigendian.patch \
32 file://arm-nolibfloat.patch \
33 file://arm-softfloat.patch \
34 file://gcc41-configure.in.patch \
35 file://arm-thumb.patch \
36 file://arm-thumb-cache.patch \
37 file://ldflags.patch \
38 file://zecke-xgcc-cpp.patch \
39 file://unbreak-armv4t.patch \
40 file://fix-ICE-in-arm_unwind_emit_set.diff \
41 file://cache-amnesia.patch \
42 file://gfortran.patch \
43 file://gcc-4.0.2-e300c2c3.patch \
44 file://pr34130.patch \
47 SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch "
49 SRC_URI_avr32 = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
50 # file://100-uclibc-conf.patch \
51 # file://200-uclibc-locale.patch \
52 # file://300-libstdc++-pic.patch \
53 file://301-missing-execinfo_h.patch \
54 file://302-c99-snprintf.patch \
55 file://303-c99-complex-ugly-hack.patch \
56 file://304-index_macro.patch \
57 file://602-sdk-libstdc++-includes.patch \
58 file://gcc41-configure.in.patch \
59 file://ldflags.patch \
60 file://zecke-xgcc-cpp.patch \
61 file://cache-amnesia.patch \
64 do_compile_prepend_avr32() {
65 ln -sf ${S}/libstdc++-v3/config/os/uclibc/ ${S}/libstdc++-v3/config/os/uclibc-linux
68 #Set the fortran bits
69 # ',fortran' or '', not 'f77' like gcc3 had
70 FORTRAN = ""
71 HAS_GFORTRAN = "no"
72 HAS_G2C = "no"
74 #Set the java bits
75 JAVA = ""
76 JAVA_arm = ""
79 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
80 require ../gcc/gcc-${PV}.inc
83 EXTRA_OECONF += " --disable-libssp --with-slibdir=\"/lib\" "
85 EXTRA_OEMAKE += "LDFLAGS=\"-static\" build_tooldir=\"${STAGING_DIR}/${TARGET_SYS}\""
87 CONFIG_SITE=""
89 do_configure () {
90 export CPP="gcc -E"
91 export CC=gcc
92 export AS=as
93 export LD=ld
94 export CXX=g++
95 export AR=ar
96 export OBJCOPY=objcopy
97 export OBJDUMP=objdump
98 export RANLIB=ranlib
99 export NM=nm
100 export STRIP=strip
101 export CFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
102 export CXXFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
103 oe_runconf
106 SRC_URI[md5sum] = "a4a3eb15c96030906d8494959eeda23c"
107 SRC_URI[sha256sum] = "cfc0efbcc6fcde0d416a32dfb246c9df022515a312683fac412578c4fd09a9bc"