linux-omap 2.6.39: sync with meta-texasinstruments
[openembedded.git] / recipes / gstreamer / gst-ffmpeg_0.10.11.bb
blob563521e7c43e88d46d7c18f6f0c96454af850d40
1 DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 HOMEPAGE = "http://www.gstreamer.net/"
6 DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
8 PR = "r1"
10 inherit autotools pkgconfig
12 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
13 file://lower-rank.diff \
16 SRC_URI[md5sum] = "0d23197ba7ac06ea34fa66d38469ebe5"
17 SRC_URI[sha256sum] = "ff36a138e5af4ed8dcc459d6d6521fe66ed31ec29ba9a924dc3675c6749a692e"
19 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
20 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
21 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
23 EXTRA_OECONF = " --with-system-ffmpeg "
25 # We do this because the install program is called with -s which causes it to
26 # call "strip" and it then mangles cross compiled stuff..
27 PATH_prepend := "${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"