linux-omap 2.6.39: sync with meta-texasinstruments
[openembedded.git] / recipes / glibc / glibc_cvs.bb
blob4281b5d0b9842708f01e6de2c8b91bd77865ee26
1 require glibc.inc
3 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
4 PR = "${INC_PR}.0"
5 PV = "2.3.5+cvs${SRCDATE}"
7 GLIBC_ADDONS ?= "ports,linuxthreads"
9 DEFAULT_PREFERENCE = "-1"
12 # For now, we will skip building of a gcc package if it is a uclibc one
13 # and our build is not a uclibc one, and we skip a glibc one if our build
14 # is a uclibc build.
16 # See the note in gcc/gcc_3.4.0.oe
19 python __anonymous () {
20 import bb, re
21 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
22 if uc_os:
23 raise bb.parse.SkipPackage("incompatible with target %s" %
24 bb.data.getVar('TARGET_OS', d, 1))
27 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
28 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
30 # file://noinfo.patch
31 # file://ldconfig.patch;striplevel=0
32 # file://arm-no-hwcap.patch;striplevel=0 \
33 # file://arm-memcpy.patch;striplevel=0 \
34 # file://arm-machine-gmon.patch;striplevel=0 \
35 # \
36 # file://arm-ioperm.patch;striplevel=0 \
37 # file://ldd.patch;striplevel=0 \
38 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc \
39 cvs://anoncvs@sources.redhat.com/cvs/glibc;module=ports \
40 file://nscd-init.patch;striplevel=0 \
41 file://arm-audit.patch \
42 file://arm-audit2.patch \
43 file://arm-memcpy.patch \
44 file://arm-longlong.patch;striplevel=0 \
45 file://fhs-linux-paths.patch \
46 file://dl-cache-libcmp.patch \
47 file://ldsocache-varrun.patch \
48 file://etc/ld.so.conf \
49 file://generate-supported.mk"
51 # seems to fail on tls platforms
52 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch"
54 S = "${WORKDIR}/libc"
55 B = "${WORKDIR}/build-${TARGET_SYS}"
57 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
58 --without-cvs --disable-profile --disable-debug --without-gd \
59 --enable-clocale=gnu \
60 --enable-add-ons=${GLIBC_ADDONS} \
61 --with-headers=${STAGING_INCDIR} \
62 --without-selinux \
63 ${GLIBC_EXTRA_OECONF}"
65 EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
67 do_munge() {
68 # Integrate ports into tree
69 mv ${WORKDIR}/ports ${S}
72 addtask munge before do_patch after do_unpack
74 do_configure () {
75 # /var/db was not included to FHS
76 sed -i s:/var/db/nscd:/var/run/nscd: ${S}/nscd/nscd.h
77 # override this function to avoid the autoconf/automake/aclocal/autoheader
78 # calls for now
79 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
80 # version check and doesn't really help with anything
81 if [ -z "`which rpcgen`" ]; then
82 echo "rpcgen not found. Install glibc-devel."
83 exit 1
85 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
86 CPPFLAGS="" oe_runconf
89 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
90 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
91 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
93 do_compile () {
94 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
95 unset LDFLAGS
96 base_do_compile
98 cd ${S}/sunrpc/rpcsvc
99 for r in ${rpcsvc}; do
100 h=`echo $r|sed -e's,\.x$,.h,'`
101 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
102 done
106 require glibc-stage.inc
108 require glibc-package.inc