linux-omap 2.6.39: sync with meta-texasinstruments
[openembedded.git] / recipes / ffmpeg / ffmpeg_git.bb
blob9cbd086efec11f0e1d46ee34dcb70db745d074ce
1 require ffmpeg.inc
3 DEPENDS += "virtual/libsdl schroedinger libgsm libvpx"
5 # When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
6 SRCREV = "0b32da90f893b3e04ead18a546252e241a6a0988"
8 PV = "0.6.1+${PR}+gitr${SRCPV}"
9 PR = "${INC_PR}.2"
11 DEFAULT_PREFERENCE = "-1"
12 DEFAULT_PREFERENCE_angstrom = "1"
13 DEFAULT_PREFERENCE_shr = "1"
15 SRC_URI = "git://git.libav.org/libav.git;protocol=git"
17 S = "${WORKDIR}/git"
18 B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
20 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fno-tree-vectorize -fomit-frame-pointer -O4 -ffast-math"
21 BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
23 EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
24 EXTRA_FFCONF ?= ""
26 EXTRA_OECONF = " \
27 --enable-shared \
28 --enable-pthreads \
29 --disable-stripping \
30 --enable-gpl \
31 --enable-postproc \
33 --cross-prefix=${TARGET_PREFIX} \
34 --prefix=${prefix} \
36 --enable-ffserver \
37 --enable-ffplay \
38 --enable-x11grab \
39 --enable-libgsm \
40 --enable-libmp3lame \
41 --enable-libschroedinger \
42 --enable-libtheora \
43 --enable-libvorbis \
44 --enable-libvpx \
45 --arch=${TARGET_ARCH} \
46 --target-os="linux" \
47 --enable-cross-compile \
48 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
49 --extra-ldflags="${TARGET_LDFLAGS}" \
50 --sysroot="${STAGING_DIR_TARGET}" \
51 --enable-hardcoded-tables \
52 ${EXTRA_FFCONF} \
55 do_configure() {
56 # sed -i -e s:'check_cflags -std=c99'::g ${S}/configure
57 mkdir -p ${B}
58 cd ${B}
59 ${S}/configure ${EXTRA_OECONF}
60 sed -i -e s:Os:O4:g ${B}/config.h