1 DESCRIPTION
= "The GNU cc and gcc C compilers."
2 HOMEPAGE
= "http://www.gnu.org/software/gcc/"
5 # NOTE
: split PR.
If the main .bb changes something that affects its
*build
*
6 # remember
to increment the
-cross .bb PR too.
11 RCONFLICTS_g
++-noemu
= "g++"
12 RREPLACES_g
++-noemu
= "g++"
13 RCONFLICTS_cpp
-noemu
= "cpp"
14 RREPLACES_cpp
-noemu
= "cpp"
16 inherit autotools gettext
18 require gcc
-package
-noemu.inc
20 SRC_URI
= "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
21 file://100-uclibc-conf.patch;patch=1 \
22 file://110-arm-eabi.patch;patch=1 \
23 file://200-uclibc-locale.patch;patch=1 \
24 file://300-libstdc++-pic.patch;patch=1 \
25 file://301-missing-execinfo_h.patch;patch=1 \
26 file://302-c99-snprintf.patch;patch=1 \
27 file://303-c99-complex-ugly-hack.patch;patch=1 \
28 file://304-index_macro.patch;patch=1 \
29 file://602-sdk-libstdc++-includes.patch;patch=1 \
30 file://740-sh-pr24836.patch;patch=1 \
31 file://800-arm-bigendian.patch;patch=1 \
32 file://arm-nolibfloat.patch;patch=1 \
33 file://arm-softfloat.patch;patch=1 \
34 file://gcc41-configure.in.patch;patch=1 \
35 file://arm-thumb.patch;patch=1 \
36 file://arm-thumb-cache.patch;patch=1 \
37 file://ldflags.patch;patch=1 \
38 file://zecke-xgcc-cpp.patch;patch=1 \
39 file://unbreak-armv4t.patch;patch=1 \
40 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
41 file://cache-amnesia.patch;patch=1 \
42 file://gfortran.patch;patch=1 \
43 file://gcc-4.0.2-e300c2c3.patch;patch=1 \
44 file://pr34130.patch;patch=1 \
47 SRC_URI_append_sh3
= " file://sh3-installfix-fixheaders.patch;patch=1 "
49 SRC_URI_avr32
= "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
50 # file://100-uclibc-conf.patch;patch=1 \
51 # file://200-uclibc-locale.patch;patch=1 \
52 # file://300-libstdc++-pic.patch;patch=1 \
53 file://301-missing-execinfo_h.patch;patch=1 \
54 file://302-c99-snprintf.patch;patch=1 \
55 file://303-c99-complex-ugly-hack.patch;patch=1 \
56 file://304-index_macro.patch;patch=1 \
57 file://602-sdk-libstdc++-includes.patch;patch=1 \
58 file://gcc41-configure.in.patch;patch=1 \
59 file://ldflags.patch;patch=1 \
60 file://zecke-xgcc-cpp.patch;patch=1 \
61 file://cache-amnesia.patch;patch=1 \
64 do_compile_prepend_avr32
() {
65 ln
-sf $
{S
}/libstdc
++-v3
/config
/os
/uclibc
/ $
{S
}/libstdc
++-v3
/config
/os
/uclibc
-linux
69 # '
,fortran'
or ''
, not 'f77' like gcc3 had
79 LANGUAGES
= "c,c++${FORTRAN}${JAVA}"
80 require recipes
/gcc
/gcc
-$
{PV
}.inc
83 EXTRA_OECONF
+= " --disable-libssp --with-slibdir=\"/lib\" "
85 EXTRA_OEMAKE
+= "LDFLAGS=\"-static\" build_tooldir=\"${STAGING_DIR}/${TARGET_SYS}\""
96 export OBJCOPY
=objcopy
97 export OBJDUMP
=objdump
101 export CFLAGS
="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
102 export CXXFLAGS
="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"