mtd-utils_1.2.0+git: remove the second docfdisk from the binary list
[openembedded.git] / packages / quake / quake2_svn.bb
blob31491ad4198184ef4881d977d714cebb3416b864
1 DESCRIPTION = "Icculus.org quake2 engine"
2 LICENSE = "GPL"
4 DEPENDS = "libsdl-x11 libxxf86dga"
6 SRCREV = "205"
7 PV = "0.16.1+svnr${SRCREV}"
9 SRC_URI = "svn://svn.icculus.org/quake2/;module=trunk \
10 file://quake2-arm.patch;patch=1"
12 S = "${WORKDIR}/trunk"
14 export BUILD_SDLQUAKE2=YES
15 export OSTYPE=Linux
16 export ARCH=${TARGET_ARCH}
17 export BASE_CFLAGS="${TARGET_CC_ARCH} -Wall -pipe -Dstricmp=strcasecmp"
18 export OPT_CFLAGS="-O3 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations"
20 do_compile() {
21 sed -i -e s:=gcc:=${TARGET_PREFIX}gcc:g Makefile
22 oe_runmake -e
25 do_install() {
26 install -d ${D}/${bindir}
27 echo -e "#!/bin/sh \ncd ${libdir}/quake2 && ./quake2 \$@ \n" > ${D}/${bindir}/quake2
29 ( cd ${S}/debug${TARGET_ARCH} ; ln -sf game$(uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/).so game${TARGET_ARCH}.so )
30 install -d ${D}/${libdir}/quake2/baseq2/ctf
31 install -m 0755 ${S}/debug${TARGET_ARCH}/game${TARGET_ARCH}.so ${D}/${libdir}/quake2/baseq2
32 install -m 0755 ${S}/debug${TARGET_ARCH}/ref*.so ${D}/${libdir}/quake2
33 install -m 0755 ${S}/debug${TARGET_ARCH}/ctf/*.so ${D}/${libdir}/quake2/baseq2/ctf
34 install -m 0755 ${S}/debug${TARGET_ARCH}/quake2 ${D}/${libdir}/quake2
37 FILES_${PN} += "${libdir}"
38 FILES_${PN}-dbg += "${libdir}/quake2/baseq2/.debug ${libdir}/quake2/baseq2/ctf/.debug"