yavta: import from meta-oe
[openembedded.git] / recipes / monotone / monotone-6_0.37.bb
blobd4c40c247a9feafa8db78e38a40fcbf6e191ad21
1 DESCRIPTION = "Monotone is a distributed Source Control System"
2 HOMEPAGE = "http://www.monotone.ca/"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6 DEPENDS = "boost"
8 PROVIDES = "monotone"
9 RPROVIDES_${PN} = "monotone"
11 S = "${WORKDIR}/monotone-${PV}"
12 # no cross compile support - it tries to run the test program even with
13 # --enable_ipv6=yes
14 EXTRA_OECONF = "--disable-ipv6 \
15 --disable-dependency-tracking \
16 --disable-rpath \
17 --disable-nls \
18 --with-gnu-ld \
19 --with-bundled-lua --with-bundled-sqlite"
21 inherit autotools
23 # Release 0.22 reveals bugs in g++ for thumb (g++ generates
24 # relocations which the linker cannot represent)
25 #FIXME: remove the following
26 ARM_INSTRUCTION_SET = "arm"
28 PR = "r1"
30 SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
31 file://txt2c-cross-post-0.22.patch \
32 # file://uclibc.database.hh.stdarg.patch \
33 file://configure.ac-no-sync-with-stdio-0.31.patch \
35 do_compile_append() {
36 touch testsuite
39 # This makes the testsuite as a package and renames the monotone executable
40 # to include the netsync suffix.
41 do_install_append() {
42 install -d ${D}${tsd}
43 install -c -m 755 testsuite ${D}${tsd}/testsuite
44 cp -pPR tests ${D}${tsd}/tests
45 rm ${D}/home/monotone/monotone-6/tests/diff_a_binary_file/binary
48 PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-testsuite"
49 tsd = "/home/monotone/${PN}"
50 FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
51 RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
54 SRC_URI[md5sum] = "d06193f2738626570692bed2173144c1"
55 SRC_URI[sha256sum] = "061e2f6aa0a1c0105b105946744d84c44eb49e9a4fe4628e872c518533b6ec2d"