llvm-common: use do_install to do the stuff
[openembedded.git] / classes / pkgconfig.bbclass
blobcf37ca16edad3ad60374908f204b6fd779776b5e
1 DEPENDS_prepend = "pkgconfig-native "
3 do_install_prepend () {
4         for i in `find ${S}/ -name "*.pc" -type f` ; do \
5                 sed -i -e 's:-L${STAGING_LIBDIR}::g' \
6                         -e 's:-R${STAGING_LIBDIR}::g' \
7                         -e 's:-I${STAGING_INCDIR}::g' \
8                         $i
9         done
12 SYSROOT_PREPROCESS_FUNCS += "pkgconfig_sysroot_preprocess"
14 pkgconfig_sysroot_preprocess () {
15         install -d ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}
16         for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
17                 pcname=`basename $pc`
18                 cat $pc > ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}/$pcname
19         done