llvm-common: use do_install to do the stuff
[openembedded.git] / classes / gettext.bbclass
blob968531b4eda4aa4bb0e2657f324bb53f2c250f92
1 def gettext_after_parse(d):
2     # Remove the NLS bits if USE_NLS is no.
3     if bb.data.getVar('USE_NLS', d, 1) == 'no':
4         cfg = oe_filter_out('^--(dis|en)able-nls$', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
5         cfg += " --disable-nls"
6         depends = bb.data.getVar('DEPENDS', d, 1) or ""
7         bb.data.setVar('DEPENDS', oe_filter_out('^(gettext|gettext-native)$', depends, d), d)
8         bb.data.setVar('EXTRA_OECONF', cfg, d)
10 python () {
11     gettext_after_parse(d)
14 DEPENDS_GETTEXT = "gettext gettext-native virtual/libiconv virtual/libintl"
16 DEPENDS =+ "${DEPENDS_GETTEXT}"
17 EXTRA_OECONF += "--enable-nls"