chinook-compat: add new toolchain options and stick to util-linux
[openembedded.git] / recipes / tasks / task-openmoko-ui.bb
blob71020afef621a0a0c60b2c6ad3a862a439146811
1 DESCRIPTION = "Openmoko: GUI for the Openmoko Linux Distribution"
2 SECTION = "openmoko/base"
3 LICENSE = "MIT"
4 PR = "r73"
6 inherit task
8 XSERVER ?= "xserver-kdrive-fbdev"
11 # task-openmoko-ui
13 DESCRIPTION_task-openmoko-ui = "Openmoko: The X11/Gtk+2 based native User Interface"
14 PACKAGE_ARCH_task-openmoko-ui = "${MACHINE_ARCH}"
15 RDEPENDS_task-openmoko-ui = "\
16 gdk-pixbuf-loader-png \
17 gdk-pixbuf-loader-gif \
18 gdk-pixbuf-loader-xpm \
19 gdk-pixbuf-loader-jpeg \
20 pango-module-basic-x \
21 pango-module-basic-fc \
22 gtk+ \
23 matchbox-wm \
24 ${XSERVER} \
25 xserver-kdrive-common \
26 xserver-nodm-init \
27 xauth \
28 xhost \
29 xset \
30 xrandr \
32 settings-daemon \
33 notification-daemon \
34 neod \
35 libnotify \
37 openmoko-session2 \
38 openmoko-sound-system2 \
39 openmoko-sound-theme-standard2 \
41 gpe-scap \
44 # Handle theming. FIXME: properly use machine database in a smart way,
45 # taking into account not only size but also PPI! Ultimately this might
46 # need recomputing some theme files and images on-the-fly :/ SVG and logical
47 # theme description anyone? Or simply Edje to the rescue! :D
48 THEMES = "openmoko-icon-theme-standard2 moko-gtk-engine"
49 THEMES_a780 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
50 THEMES_e680 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
51 THEMES_a1200 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
52 THEMES_rokre2 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
53 THEMES_rokre6 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
54 THEMES_magician = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
55 THEMES_chumby = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
56 THEMES_htcblueangel = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
58 RDEPENDS_task-openmoko-ui += "${THEMES}"