chinook-compat: add new toolchain options and stick to util-linux
[openembedded.git] / recipes / libmad / libmad_0.15.1b.bb
blob738dcc216091dea181caa19f57e10535e5217dbc
1 DESCRIPTION = "MPEG Audio Decoder Library"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "libid3tag"
5 LICENSE = "GPL"
6 PR = "r4"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/mad/libmad-${PV}.tar.gz \
9 file://add-pkgconfig.patch;patch=1 \
10 file://mad.diff;patch=1 \
11 file://mad-mips-h-constraint.patch;patch=1"
13 S = "${WORKDIR}/libmad-${PV}"
15 SRC_URI_append_avr32 = " file://libmad-0.15.1b-avr32-optimization.patch;patch=1"
17 inherit autotools pkgconfig
19 EXTRA_OECONF = "-enable-speed --enable-shared"
20 # The ASO's don't take any account of thumb...
21 EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
22 EXTRA_OECONF_append_arm = " --enable-fpm=arm"
24 do_configure_prepend () {
25 # damn picky automake...
26 touch NEWS AUTHORS ChangeLog
29 do_stage() {
30 oe_libinstall -so libmad ${STAGING_LIBDIR}
31 install -m 0644 mad.h ${STAGING_INCDIR}
34 ARM_INSTRUCTION_SET = "arm"