chinook-compat: add new toolchain options and stick to util-linux
[openembedded.git] / recipes / led / led_cvs.bb
blob7d3b76c6f505529e8b9b37a266073db5c1c4bd79
1 SECTION = "base"
2 LICENSE= "GPL"
3 PV = "0.0cvs${SRCDATE}"
4 DESCRIPTION = "Command line tool for iPaq LED control"
6 SRC_URI = "${HANDHELDS_CVS};module=apps/h3600_test \
7 file://nokernelheader.patch;patch=1;pnum=0"
8 inherit module-base
10 S = "${WORKDIR}/h3600_test"
11 PR = "r0"
13 inherit pkgconfig
15 FILES_${PN} = "${bindir}"
17 do_configure (){
20 do_compile (){
21 oe_runmake led CC="${CROSS_DIR}/bin/${TARGET_SYS}-gcc -I${STAGING_INCDIR} -I${STAGING_KERNEL_DIR}/include -L${STAGING_LIBDIR}" AS=${CROSS_DIR}/bin/${TARGET_SYS}-as LD=${CROSS_DIR}/bin/${TARGET_SYS}-ld
24 do_install () {
25 install -d ${D}${bindir}
26 install -m 4755 ${S}/led ${D}${bindir}/led