chinook-compat: add new toolchain options and stick to util-linux
[openembedded.git] / recipes / freenote / freenote_1.12.0.bb
blob8f77776131dca3e5f0411984af7b6a10f0934dd2
1 DESCRIPTION = "Auto-Correction Paint Program for Opie/Qtopia"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 APPNAME = "FreeNote"
6 APPTYPE = "binary"
7 APPDESKTOP = "apps/Applications"
9 SRC_URI = "http://www.urban.ne.jp/home/kanemori/zaurus/FreeNote_1.12.0.tar.gz \
10 file://FreeNote"
11 S = "${WORKDIR}/FreeNote"
13 inherit opie
15 do_configure_prepend() {
16 mv -f FreeNote subdir1
17 mv -f FreeNoteSetup subdir2
18 printf "TEMPLATE=subdirs\nSUBDIRS=subdir1 subdir2\n" >> freenote.pro
19 cd ${S}/subdir1 && rm *.pro && qmake -project && echo "TARGET=FreeNote" >> subdir1.pro
20 cd ${S}/subdir2 && rm *.pro && qmake -project && echo "TARGET=FreeNoteSetup" >> subdir2.pro
21 cd ${S}
24 do_install() {
25 install -d ${D}${palmtopdir}/bin/
26 install -m 0755 FreeNoteSetup ${D}${palmtopdir}/bin/
27 install -d ${D}${palmtopdir}/pics/
28 install -m 0644 pics/freenote.png ${D}${palmtopdir}/pics
29 install -m 0644 pics/fnsetup.png ${D}${palmtopdir}/pics
30 install -d ${D}${palmtopdir}/apps/Applications
31 install -m 0644 apps/Applications/FreeNote.desktop ${D}${palmtopdir}/apps/Applications
32 install -d ${D}${palmtopdir}/apps/Settings
33 install -m 0644 apps/Settings/FreeNoteSetup.desktop ${D}${palmtopdir}/apps/Settings