llvm-common: use do_stage for now, until there is a better solution
[openembedded.git] / recipes / neuros-public / neuros-nwm_git.bb
blob258842afa486e83f6f39cd2cb8f21b25eb6a2a2c
1 DESCRIPTION = "Neuros window manager"
2 LICENSE = "GPL"
4 PV = "0.0+${PR}+gitr${SRCREV}"
5 PR = "r7"
7 inherit qt4e update-rc.d
9 SRCREV = "b042e49d3a71cea6d4545ef6f2fc90979518b22e"
10 SRC_URI = "git://git.neurostechnology.com/git/app-nwm;protocol=git \
11 file://init"
13 INITSCRIPT_NAME = "neuros-nwm"
15 S = "${WORKDIR}/git/"
17 do_configure_prepend() {
18 rm ${S}/src/Makefile || true
19 sed -i -e s:/usr/locl/bin:${bindir}:g ${WORKDIR}/init
22 do_install() {
23 install -d ${D}/${bindir}
24 install -m 0755 ${S}/build/nwm ${D}/${bindir}
25 install -d ${D}/${libdir}
26 ln -sf ${datadir}/fonts ${D}/${libdir}/fonts
28 install -d ${D}/${sysconfdir}/init.d
29 install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/neuros-nwm
32 FILES_${PN} += "${libdir}/fonts"