llvm-common: use do_stage for now, until there is a better solution
[openembedded.git] / recipes / llvm / llvm-common.bb
blob861ae4ef02efb24b82303fb41e4a33aaba099d1d
1 DESCRIPTION = "Helper script for OE's llvm support"
3 PR = "r2"
5 BBCLASSEXTEND = "native"
7 SRC_URI = "file://llvm-config"
9 PACKAGES = ""
11 # For llvm-common the script should end up in STAGING_BINDIR_CROSS
12 # and for llvm-common-native it should be in STAGING_BINDIR. The
13 # script works together with a script that is installed by a
14 # corresponding llvm(-native) package.
15 DESTINATION = "${STAGING_BINDIR_CROSS}"
16 DESTINATION_virtclass-native = "${STAGING_BINDIR}"
18 do_stage() {
19 install -d ${DESTINATION}
20 install -m 0755 ${WORKDIR}/llvm-config ${DESTINATION}