llvm-common: use do_stage for now, until there is a better solution
[openembedded.git] / recipes / libgpepimc / libgpepimc_0.2.bb
blobf7887db43b3798e9fde5c0127695937d3046e8c7
1 LICENSE = "LGPL"
2 DESCRIPTION = "Common code for GPE PIMs"
3 SECTION = "gpe/libs"
4 PRIORITY = "optional"
5 DEPENDS = "libgpewidget libdisplaymigration gtk+ sqlite"
7 inherit pkgconfig gpe
9 SRC_URI += "file://libgpepimc_pc.patch"
11 headers = "pim-categories.h pim-categories-ui.h"
13 do_stage () {
14 oe_libinstall -so libgpepimc ${STAGING_LIBDIR}
16 mkdir -p ${STAGING_INCDIR}/gpe
17 for h in ${headers}; do
18 install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
19 done
22 do_install () {
23 gpe_do_install
24 oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
27 SRC_URI[md5sum] = "74e36fd1c34dc668801366d5aa11e93e"
28 SRC_URI[sha256sum] = "19556cc4d3469f61c7b50db7a9979a669af0b03c0c2243441e34a8a5f737fa9d"