aurora-fb-image: add initial recipe for aurora based image suitable for the framebuffer
[openembedded.git] / recipes / meta / external-toolchain.bb
blob77b479cffe782e4dbddddb6433b61fc5feac8507
1 DESCRIPTION = "This package allows OE to work with an external toolchain generated \
2 by meta-toolchain instead of building its own. It expects that toolchain \
3 to be located in SDK_PATH/prefix."
5 PROVIDES = "\
6 linux-libc-headers \
7 virtual/${TARGET_PREFIX}gcc \
8 virtual/${TARGET_PREFIX}gcc-initial \
9 virtual/${TARGET_PREFIX}gcc-intermediate \
10 virtual/${TARGET_PREFIX}binutils \
11 virtual/${TARGET_PREFIX}libc-for-gcc \
12 virtual/libc \
13 virtual/libintl \
14 virtual/libiconv \
17 RPROVIDES_${PN} = "glibc-utils libsegfault glibc-thread-db libgcc-dev libgcc libstdc++-dev libstdc++"
18 PACKAGES_DYNAMIC = "glibc-gconv-*"
19 PR = "r3"
21 inherit sdk
23 do_stage() {
24 if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
25 echo "The package status file of the external toolchain could not be found in ${prefix}!"
26 exit 1
29 install -d ${STAGING_DIR}/pkgdata/
30 install -d ${STAGING_DIR_TARGET}/shlibs/
32 cp -pPRr ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
33 cp -pPRr ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
35 if [ -d ${prefix}/ipk ]; then
36 install -d ${DEPLOY_DIR_IPK}/
37 cp -pPRr ${prefix}/ipk/* ${DEPLOY_DIR_IPK}/
40 if [ -d ${prefix}/deb ]; then
41 install -d ${DEPLOY_DIR_DEB}/
42 cp -pPRr ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
45 if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
46 install -d ${DEPLOY_DIR_PSTAGE}/
47 cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/