aurora-fb-image: add initial recipe for aurora based image suitable for the framebuffer
[openembedded.git] / recipes / meta / external-toolchain-generic.bb
blob53a5f90f1e5d7a067cd0c134f47c9271f1aa0878
1 DESCRIPTION = "This package allows OE to work with an external toolchain generated \
2 by meta-toolchain instead of building its own. It expects that toolchain \
3 to be located in SDK_PATH/prefix."
5 PROVIDES = "\
6 linux-libc-headers \
7 virtual/${TARGET_PREFIX}gcc \
8 virtual/${TARGET_PREFIX}gcc-initial \
9 virtual/${TARGET_PREFIX}gcc-intermediate \
10 virtual/${TARGET_PREFIX}binutils \
11 virtual/${TARGET_PREFIX}libc-for-gcc \
12 virtual/${TARGET_PREFIX}libc-initial \
13 virtual/libc \
14 virtual/libintl \
15 virtual/libiconv \
18 RPROVIDES_${PN} = "glibc glibc-utils libsegfault glibc-thread-db libgcc-dev libgcc libstdc++-dev libstdc++ ldd"
19 PACKAGES_DYNAMIC = "glibc-gconv-*"
20 PR = "r3"
22 inherit sdk
24 do_stage() {
25 if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
26 echo "The package status file of the external toolchain could not be found in ${prefix}!"
27 exit 1
30 install -d ${STAGING_DIR}/pkgdata/
31 install -d ${STAGING_DIR_TARGET}/shlibs/
33 cp -pPRr ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
34 cp -pPRr ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
36 if [ -d ${prefix}/ipk ]; then
37 install -d ${DEPLOY_DIR_IPK}/
38 cp -pPRr ${prefix}/ipk/* ${DEPLOY_DIR_IPK}/
41 if [ -d ${prefix}/deb ]; then
42 install -d ${DEPLOY_DIR_DEB}/
43 cp -pPRr ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
46 if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
47 install -d ${DEPLOY_DIR_PSTAGE}/
48 cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/