aurora-fb-image: add initial recipe for aurora based image suitable for the framebuffer
[openembedded.git] / recipes / hostap / hostap-conf_1.0.bb
bloba3c56d6694eff35072861862086f2e52f5b86f58
1 DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 RDEPENDS_${PN} = "update-modules"
6 PACKAGE_ARCH = "all"
7 PR = "r11"
9 SRC_URI = "file://hostap_cs.conf \
10 file://hostap_cs.modalias \
11 file://hostap_cs.conf-upstream"
13 do_compile() {
16 do_install() {
17 install -d ${D}${sysconfdir}/pcmcia
18 install -d ${D}${sysconfdir}/modutils
20 install -m 0644 ${WORKDIR}/hostap_cs.conf-upstream ${D}${sysconfdir}/pcmcia/hostap_cs.conf
21 cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
23 install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
26 pkg_postinst () {
27 if [ -n "$D" ]; then
28 exit 1
30 update-modules || true
33 pkg_postrm () {
34 update-modules || true