aurora-fb-image: add initial recipe for aurora based image suitable for the framebuffer
[openembedded.git] / recipes / dillo / dillo2_2.1.1.bb
blob69b9c65f05cacb62ae05c90b9c27c9cf755e776c
1 DESCRIPTION = "Lightweight fltk2 browser, with support for SSL, tabs and much more..."
2 HOMEPAGE = "http://www.dillo.org"
3 SECTION = "x11/network"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk2 libpng openssl"
7 RDEPENDS_${PN} = "fltk2-images"
8 SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.bz2 \
9 file://dillo.desktop \
10 file://dillo.png"
11 PR = "r6"
13 S = "${WORKDIR}/dillo-${PV}/"
15 inherit autotools pkgconfig
17 FILES_${PN} += " /usr/lib/dillo/ /usr/bin/dpid /usr/bin/dpidc "
18 FILES_${PN}-dbg += " ${libdir}/dillo/dpi/*/.debug/"
21 EXTRA_OECONF = "--enable-ipv6 --enable-ssl"
23 do_install_append() {
24 install -d ${D}${datadir}/applications
25 install -d ${D}${datadir}/pixmaps
26 install -m 0644 ${WORKDIR}/dillo.desktop ${D}${datadir}/applications/dillo.desktop
27 install -m 0644 ${WORKDIR}/dillo.png ${D}${datadir}/pixmaps/dillo.png
30 SRC_URI[md5sum] = "93f674f2a42d90a1cdb88a6972325954"
31 SRC_URI[sha256sum] = "8eec025872030fc1419fb93ee41dbdf380a6d1f75f4d51aec5eee9a9a4aa4477"