fsoaudiod: package even the alsa-plugin and bump PR
[openembedded.git] / recipes / freesmartphone / fsoaudiod_git.bb
bloba6f1933b927f57e854940cbc3a3a22f95465673c
1 require cornucopia.inc
2 inherit fso-plugin
4 LICENSE = "LGPLv2.1"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=78aab3f7875ffe21aebed9932fa3f993"
7 DEPENDS += "alsa-lib"
9 # We need to uncomment the line below after the migration of all scenario files from
10 # fsodeviced to fsoaudiod is done. Otherwise we will get build errors as both fsodeviced
11 # and fsoaudiod are dependencies of the FSO framework.
12 # PROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
14 SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
15 PV = "0.1.0+gitr${SRCPV}"
16 PE = "2"
17 PR = "${INC_PR}.3"
19 inherit update-rc.d
21 INITSCRIPT_NAME = "fsoaudiod"
22 INITSCRIPT_PARAMS = "defaults 30"
24 SRC_URI += "file://fsoaudiod"
26 CONFFILES_${PN} = " \
27 ${sysconfdir}/freesmartphone/conf/palm_pre/fsoaudiod.conf \
28 ${sysconfdir}/asound.conf \
30 RCONFLICTS_${PN} = "alsa-state"
32 do_install_append() {
33 install -d ${D}${sysconfdir}/init.d/
34 install -m 0755 ${WORKDIR}/fsoaudiod ${D}${sysconfdir}/init.d/
37 PACKAGES =+ "${PN}-alsa-plugins ${PN}-alsa-plugins-dbg ${PN}-alsa-plugins-dev"
38 FILES_${PN}-alsa-plugins = "${libdir}/alsa-lib/fsoaudio_session.so"
39 FILES_${PN}-alsa-plugins-dev = "${libdir}/alsa-lib/fsoaudio_session.la"
40 FILES_${PN}-alsa-plugins-dbg = "${libdir}/alsa-lib/.debug/fsoaudio_session.so"