angstrom-task-gnome: bump PR
[openembedded.git] / recipes / tasks / angstrom-task-gnome.bb
blob8b3f09bb4afbd2285c949480166060dd55455448
1 DESCRIPTION = "Task for a GNOME based image"
3 inherit task
5 # Most of these tasks are arch independant
6 PACKAGE_ARCH = "all"
8 XSERVER ?= "xserver-xorg \
9 xf86-input-evdev \
10 xf86-input-mouse \
11 xf86-video-fbdev \
12 xf86-input-keyboard \
15 PR = "r11"
17 PACKAGES += "task-gnome-apps task-gnome-fonts task-gnome task-gnome-gstreamer task-gnome-perl task-gnome-pulseaudio task-gnome-themes task-gnome-totem task-gnome-xserver-base task-gnome-xserver"
19 DEPENDS = "gst-plugins-ugly"
21 RDEPENDS_task-gnome-apps = " \
22 abiword \
23 cheese \
24 claws-mail \
25 epiphany epiphany-extensions \
26 swfdec swfdec-gnome swfdec-mozilla \
27 evince \
28 gcalctool \
29 gedit \
30 gimp \
31 gnome-games \
32 gnome-mplayer \
33 gecko-mediaplayer-firefox-hack \
34 gnumeric \
35 gphoto2 \
36 gthumb \
37 pidgin \
38 synergy \
39 vnc \
40 x11vnc angstrom-x11vnc-xinit \
41 xmms \
42 xterm \
43 eog \
46 RDEPENDS_task-gnome-fonts = " \
47 font-adobe-75dpi \
48 fontconfig fontconfig-utils font-util \
49 ttf-arphic-uming \
50 ttf-dejavu-common \
51 ttf-dejavu-sans \
52 ttf-dejavu-serif \
53 ttf-dejavu-sans-mono \
54 ttf-liberation-sans \
55 ttf-liberation-serif \
56 ttf-liberation-mono \
57 xorg-minimal-fonts \
60 RDEPENDS_task-gnome = " \
61 at-spi \
62 file-roller \
63 gconf gconf-editor \
64 gdm \
65 gnome-control-center \
66 gnome-applets \
67 gnome-bluetooth \
68 gnome-desktop \
69 gnome-doc-utils \
70 gnome-keyring gnome-keyring-pam-plugin libpam-meta pam-plugin-ck-connector \
71 gnome-media \
72 gnome-menus \
73 gnome-mime-data \
74 # gnome-packagekit packagekit packagekit-gtkmodule \
75 gnome-panel libpanel-applet libgweather-locationdata \
76 gnome-power-manager gnome-power-manager-applets \
77 gnome-python gnome-python-extras \
78 gnome-python-desktop \
79 gnome-screensaver \
80 gnome-session \
81 gnome-settings-daemon \
82 gnome-system-monitor \
83 gnome-system-tools system-tools-backends\
84 gnome-terminal \
85 gnome-utils \
86 gnome-vfs \
87 gnome-vfs-plugin-bzip2 \
88 gnome-vfs-plugin-computer \
89 gnome-vfs-plugin-dns-sd \
90 gnome-vfs-plugin-file \
91 gnome-vfs-plugin-ftp \
92 gnome-vfs-plugin-gzip \
93 gnome-vfs-plugin-http \
94 gnome-vfs-plugin-network \
95 gnome-vfs-plugin-nntp \
96 gnome-vfs-plugin-sftp \
97 gnome-vfs-plugin-tar \
98 gvfs \
99 libgnome-bin \
100 metacity \
101 nautilus nautilus-cd-burner desktop-file-utils gnome-mount \
102 networkmanager network-manager-applet networkmanager-openvpn modemmanager \
103 policykit-gnome policykit \
104 zenity \
107 DEPENDS_task-gnome-gstreamer = " \
108 gst-plugins-base \
109 gst-plugins-good \
110 gst-plugins-bad \
111 gst-plugins-ugly \
114 RDEPENDS_task-gnome-gstreamer = " \
115 gst-ffmpeg \
116 gst-plugin-pulse \
117 gst-plugins-base-meta \
118 gst-plugins-good-meta \
119 gst-plugins-bad-meta \
120 gst-plugins-ugly-meta \
123 RDEPENDS_task-gnome-perl = " \
124 perl \
125 task-perl-module-all \
126 libnet-dbus-perl \
127 libxml-parser-perl \
128 libxml-twig-perl \
131 RDEPENDS_task-gnome-cups = " \
132 cups \
133 cups-backend-hal \
134 # cups-gs \
135 gnome-cups-manager \
136 gtk-printbackend-cups \
137 # gutenprint \
138 hal-cups-utils \
141 RDEPENDS_task-gnome-pulseaudio = " \
142 pulseaudio-alsa-wrapper \
143 pulseaudio-esd-wrapper \
144 pulseaudio-module-gconf \
145 libasound-module-ctl-pulse \
146 libasound-module-pcm-pulse \
149 RDEPENDS_task-gnome-themes = " \
150 angstrom-gnome-icon-theme-enable \
151 gnome-icon-theme \
152 gnome-themes \
153 gtk-engine-clearlooks \
154 gtk-engine-glide \
155 gtk-engine-thinice \
156 gtk-engine-redmond95 \
157 gtk-theme-clearlooks \
158 gtk-theme-thinice \
159 gtk-theme-redmond \
160 hicolor-icon-theme \
161 sound-theme-freedesktop \
164 RDEPENDS_task-gnome-totem = " \
165 totem \
166 totem-browser-plugin \
167 totem-plugin-bemused \
168 totem-plugin-gromit \
169 totem-plugin-media-player-keys \
170 totem-plugin-ontop \
171 totem-plugin-properties \
172 totem-plugin-screensaver \
173 totem-plugin-skipto \
174 totem-plugin-thumbnail \
177 RDEPENDS_task-gnome-xserver-base = " \
178 dbus-x11 \
179 desktop-file-utils \
180 iso-codes \
181 mime-support \
182 notification-daemon inotify-tools \
183 xauth \
184 xdg-utils \
185 xhost \
186 xinetd \
187 xinit \
188 xlsfonts \
189 xrandr \
190 xrdb \
191 xrefresh \
192 xset \
193 xvinfo \
196 RDEPENDS_task-gnome-xserver = " \
197 ${XSERVER} \
200 PACKAGE_ARCH_task-gnome-xserver = "${MACHINE_ARCH}"
202 RDEPENDS_${PN} = " \
203 task-gnome-apps \
204 task-gnome-fonts \
205 task-gnome \
206 task-gnome-gstreamer \
207 task-gnome-perl \
208 task-gnome-perl \
209 task-gnome-pulseaudio \
210 task-gnome-themes \
211 task-gnome-totem \
212 task-gnome-xserver-base \
215 RRECOMMENDS_${PN} = " \
216 task-gnome-xserver \