enjoy_svn: fix dependencies and bump PR
[openembedded.git] / recipes / e17 / enjoy_svn.bb
blob919d3f041706886640621265cd687fb06d9bd758
1 DESCRIPTION = "Enjoy music player"
2 LICENSE = "LGPLv3"
3 DEPENDS = "evas ecore edje emotion lightmediascanner"
4 SRCREV = "${EFL_SRCREV}"
5 PV = "0.0+svnr${SRCPV}"
6 PR = "r1"
8 #1st needed for all formats
9 #2nd needed for mp3 playback
10 #3d needed for ogg playback
11 #4th needed for flac playback
12 #5th needed binary to create db
13 RDEPENDS += "\
14 gst-plugin-typefindfunctions gst-plugin-playbin gst-plugin-volume gst-plugin-decodebin2 \
15 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad gst-plugin-id3demux', d)} \
16 gst-plugin-ogg gst-plugin-ivorbisdec \
17 gst-plugin-flac \
18 lightmediascanner-test \
21 inherit e
24 EXTRA_OECONF = "\
25 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
29 pkg_postinst_${PN} () {
30 echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
31 echo "enjoy: Meanwhile please run:"
32 echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
33 echo "enjoy:"
34 echo "enjoy: Use test-lms -P to see available formats that can be scanned"