base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / sugar / sugar-base_0.83.2.bb
blobea225da55ae75fcd03d47497263f3cd80221b61a
1 DESCRIPTION = "Sugar base system"
2 LICENSE = "LGPLv2"
4 PR = "r2"
6 DEPENDS = "python-pygtk sugar-toolkit"
7 RDEPENDS_${PN} = "librsvg-gtk \
8 ohm-plugin-x11 ohm \
9 hippo-canvas \
10 python-datetime \
11 python-netclient \
12 python-pygtk \
13 sugar-toolkit \
14 python-logging \
15 python-dbus \
16 python-subprocess \
17 telepathy-gabble telepathy-salut telepathy-python \
18 sugar-presence-service \
19 python-crypt \
20 python-numpy \
21 python-compression \
22 python-gst \
23 python-simplejson \
24 python-misc \
25 python-xmlrpc \
26 python-compiler \
27 python-pydoc \
28 python-mmap \
29 python-doctest \
30 ssh-keygen"
32 inherit gnome distutils-base
34 SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-base/${PN}-${PV}.tar.bz2"
36 SRC_URI += "file://acinclude.m4"
38 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
40 do_configure_prepend() {
41 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
44 FILES_${PN} += "${datadir}/${PN} \
45 ${datadir}/dbus-1 \
46 ${sysconfdir} "
48 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/sugar/.debug"
50 AUTOTOOLS_STAGE_PKGCONFIG = "1"
52 SRC_URI[md5sum] = "0f05d95eaf0f8e3174a3b3e3b0afe995"
53 SRC_URI[sha256sum] = "64ece8bb8e6eddb4c7b8b4ce0aa30f07f00a86ed7b113a7957661e73616a8dc3"