base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / python / python-pylint_0.15.2.bb
blobdbcd24b4234400ac0dc4b4bfd891a06f4ed427ae
1 DESCRIPTION = "Pylint is a python tool that checks if a module satisfy a coding standard. Pylint can be seen as another \
2 pychecker since nearly all tests you can do with PyChecker can also be done with Pylint. But Pylint offers some more \
3 features, like checking line-code's length, checking if variable names are well-formed according to your coding standard,\
4 or checking if declared interfaces are truly implemented, and much more."
5 SECTION = "devel/python"
6 HOMEPAGE = "http://www.logilab.org/857"
7 PRIORITY = "optional"
8 LICENSE = "GPL"
9 RDEPENDS_${PN} = "python-logilab-common"
10 SRCNAME = "pylint"
11 PR = "ml1"
13 SRC_URI = "ftp://ftp.logilab.org/pub/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
14 S = "${WORKDIR}/${SRCNAME}-${PV}"
16 inherit distutils
18 SRC_URI[md5sum] = "98f3917fc4d0855c8f0eab9761533835"
19 SRC_URI[sha256sum] = "868c8c105427047842883efc2b1693137fae52e78017a7ae98c2e37b7c1e3f80"