base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / python / python-pygobject_2.16.0.bb
blob2bc0f74dc2f447c20c90aa167fc9660c443634ad
1 DESCRIPTION = "Python GObject bindings"
2 SECTION = "devel/python"
3 LICENSE = "LGPL"
4 DEPENDS = "python-pygobject-native-${PV}"
5 PE = "1"
6 PR = "ml2"
8 MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
10 SRC_URI = "\
11 ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
12 file://generate-constants.patch \
14 S = "${WORKDIR}/pygobject-${PV}"
16 inherit autotools distutils-base pkgconfig
18 # necessary to let the call for python-config succeed
19 export BUILD_SYS
20 export HOST_SYS
22 do_stage() {
23 autotools_stage_all
24 install -d ${STAGING_LIBDIR}/../share/pygobject/
25 cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
26 install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
27 cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
30 PACKAGES += "${PN}-lib"
32 RDEPENDS_${PN} += "python-textutils"
34 FILES_${PN} = "${libdir}/python*"
35 FILES_${PN}-lib = "${libdir}/lib*.so.*"
36 FILES_${PN}-dev += "${bindir} ${datadir}"
37 FILES_${PN}-dbg += "${libdir}/.debug"
39 SRC_URI[md5sum] = "431e7d4632163b93d1ee43cd071a389c"
40 SRC_URI[sha256sum] = "db0ab6f998bc5750aba2dfa96c8932f673914d8bf804a2c1c769b4a6e3f192d2"