base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / opensync / libopensync_0.36.bb
blob3e44680e862b9552d5614280fad3957bd4637288
1 LICENSE = "LGPL"
2 HOMEPAGE = "http://www.opensync.org/"
4 DEPENDS = "sqlite3 libxml2 glib-2.0 check"
6 SRC_URI = "http://opensync.org/download/releases/${PV}/libopensync-${PV}.tar.bz2\
7 file://cmake.patch \
8 file://build-in-src.patch \
9 file://no-python-check.patch"
11 inherit cmake pkgconfig
13 LEAD_SONAME = "libopensync.so"
15 FILES_${PN} += " ${libdir}/opensync*/formats/*.so \
16 ${libdir}/opensync*/osplugin \
17 ${datadir}/opensync*/schemas \
18 ${datadir}/opensync*/capabilities \
19 ${datadir}/opensync*/descriptions \
21 FILES_${PN}-dbg += " ${libdir}/opensync*/formats/.debug/*.so \
22 ${libdir}/opensync*/.debug/osplugin "
24 SRC_URI[md5sum] = "d8cc7835663566e3626e959d8fb531bf"
25 SRC_URI[sha256sum] = "c686d27f0818e2d8cc6277ba123c74d7210e70fa2b320c5a828eaaedd598e908"