base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / mozilla / firefox_3.6.3.bb
blob98a0e400bd3bf79fea3c788c7c5fa9f02b2c3bb6
1 DEPENDS += "cairo sqlite3 libnotify"
3 # The .pc files below have "3.6" hardcoded, fix that before using them in a newer FF version!
4 SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \
5 file://jsautocfg.h \
6 file://security-cross.patch \
7 file://Bug339782.additional.fix.diff \
8 file://Bug385583.nspr.jmp_buf.eabi.diff \
9 file://Bug405992.atomic.nspr.diff \
10 file://jemalloc-tls.patch \
11 file://0001-Remove-Werror-from-build.patch \
12 file://0002-Fix-security-cross-compile-cpu-detection-error.patch \
13 file://plugins-dir.patch \
14 file://firefox-plugin.pc \
15 file://firefox-xpcom.pc \
16 file://nspr.pc \
19 SRC_URI[archive.md5sum] = "5e4541ab23084b7b14ba228291ce2688"
20 SRC_URI[archive.sha256sum] = "35a0b35d79baa502b6c5781ed3e9c4b5eb623bdaf1940460dcf465192848a2d0"
22 S = "${WORKDIR}/mozilla-1.9.2"
24 inherit mozilla
25 require firefox.inc
27 EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
30 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
32 do_compile_prepend() {
33 cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
34 sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk