base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / mozilla / firefox_3.1b2.bb
blob8ef9f5f2c9c83f2c05b299df452be115164e3ccb
1 DEPENDS += "cairo"
3 PV = "3.0.1+3.1b2"
4 MOZPV = "3.1b2"
5 PR = "r1"
7 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build2/source/firefox-${MOZPV}-source.tar.bz2 \
8 file://jsautocfg.h \
9 file://jsautocfg-dontoverwrite.patch \
12 S = "${WORKDIR}/mozilla-central"
14 DEFAULT_PREFERENCE = "-1"
16 inherit mozilla
17 require firefox.inc
19 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
21 do_configure_prepend() {
22 sed -i -e s:'head -1':'head -n1':g client.mk
23 oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
26 do_compile_prepend() {
27 cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
28 sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
29 -e s:'$(OS_TEST)':${TARGET_ARCH}:g \
30 ${S}/security/coreconf/Linux.mk
33 do_stage() {
34 install -d ${STAGING_INCDIR}/firefox-${MOZPV}
35 cd dist/sdk/include
36 rm -rf obsolete
37 headers=`find . -name "*.h"`
38 for f in $headers
40 install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${MOZPV}/
41 done
42 # removes 2 lines that call absent headers
43 sed -e '178,179d' ${STAGING_INCDIR}/firefox-${MOZPV}/nsIServiceManager.h
47 SRC_URI[md5sum] = "c315e06cdfe9ee76aa4831ece1ed5df3"
48 SRC_URI[sha256sum] = "402ca3641f1724f5a4ec1ac3e283cd1334bd85c4b5de7744bd267454ef31259e"