base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / lrzsz / lrzsz_0.12.20.bb
blob4a4e358d58a282a921ce787762bd59ad062e21a5
1 LICENSE = "GPL"
2 SECTION = "console/network"
3 PRIORITY = "standard"
4 DESCRIPTION = "Tools for zmodem/xmodem/ymodem file transfer"
5 DEPENDS = ""
6 PR = "r4"
8 SRC_URI = "http://www.ohse.de/uwe/releases/lrzsz-${PV}.tar.gz \
9 file://autotools.patch \
10 file://makefile.patch \
11 file://gettext.patch"
13 inherit autotools gettext
15 do_install() {
16 install -d ${D}${bindir}/
17 install -m 0755 src/lrz src/lsz ${D}${bindir}/
20 pkg_postinst() {
21 for util in rz rx rb; do
22 update-alternatives --install ${bindir}/$util $util lrz 100
23 done
24 for util in sz sx sb; do
25 update-alternatives --install ${bindir}/$util $util lsz 100
26 done
29 pkg_postrm() {
30 for util in rz rx rb; do
31 update-alternatives --remove $util ${bindir}/lrz
32 done
33 for util in sz sx sb; do
34 update-alternatives --remove $util ${bindir}/lsz
35 done
37 SRC_URI[md5sum] = "b5ce6a74abc9b9eb2af94dffdfd372a4"
38 SRC_URI[sha256sum] = "c28b36b14bddb014d9e9c97c52459852f97bd405f89113f30bee45ed92728ff1"