base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / libsigc++-1.2 / libsigc++-1.2_1.2.5.bb
blob2c32f14cbf6f484b5e2d57843a3775f1fe25ce8d
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 PR = "r1"
5 LICENSE = "GPL LGPL"
6 SRC_URI = "${SOURCEFORGE_MIRROR}/libsigc/libsigc++-${PV}.tar.gz \
7 file://autofoo.patch \
8 file://pkgconfig.patch"
9 S = "${WORKDIR}/libsigc++-${PV}"
11 inherit autotools pkgconfig
13 FILES_${PN}-dev += "${libdir}/sigc++-*/"
15 acpaths = ""
17 do_stage() {
18 install -d ${STAGING_LIBDIR}/sigc++-1.2/include
19 install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
20 oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
22 install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
23 for f in sigc++/*.h
25 install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
26 done
30 SRC_URI[md5sum] = "d0d1ffcae0eced97ef4f17ce0ba81352"
31 SRC_URI[sha256sum] = "dcd6d3ea9a2c185b5286f80eefe9ac1402036b8fa21cfc742442d99579bd2b3e"