base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / jakarta-libs / bsf_2.4.0.bb
blobffaa8c69368193b4c15a386b056501b2732dc78e
1 DESCRIPTION = "Bean Scripting Framework package"
2 LICENSES = "AL2.0"
3 AUTHOR = "Apache Software Foundation"
5 SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz"
7 inherit java-library
9 DEPENDS = "fastjar-native jacl commons-logging rhino xalan-j bcel"
10 DEPENDS_virtclass-native = "fastjar-native jacl-native commons-logging-native rhino-native xalan-j-native bcel-native"
12 PR = "r1"
14 do_compile() {
15 mkdir -p build
17 oe_makeclasspath cp -s commons-logging jacl rhino bcel xalan2
19 # Remove netrexx and jython support
20 rm -Rf src/org/apache/bsf/engines/netrexx
21 rm -Rf src/org/apache/bsf/engines/jython
23 javac -sourcepath src -cp $cp -d build `find src -name "*.java"`
25 fastjar -C build -c -f ${JARFILENAME} .
29 SRC_URI[md5sum] = "7e58b2a009c0f70ab36bbef420b25c07"
30 SRC_URI[sha256sum] = "5ab58cf5738c144f4d85a4a442c2f33be2c4c502dca6e29e0c570c2a51ae6ae9"
32 NATIVE_INSTALL_WORKS = "1"
33 BBCLASSEXTEND = "native"