base.bbclass: add support for SOC_FAMILY in COMPATIBLE_MACHINES
[openembedded.git] / recipes / gpe-session-scripts / gpe-session-scripts_0.68.bb
blob66bf64afd7c0c22349576ae20a1ac8e2d6da36c3
1 inherit gpe
3 DESCRIPTION = "GPE session startup scripts"
4 LICENSE = "GPL"
5 SECTION = "gpe"
6 PRIORITY = "optional"
7 RDEPENDS_${PN} = "matchbox-panel matchbox-desktop matchbox-common gpe-session-starter xtscal gpe-question matchbox-applet-inputmanager xmodmap xdpyinfo xserver-common ipaq-sleep"
8 # more rdepends: keylaunch apmd blueprobe
9 DEPENDS = "matchbox-wm matchbox-panel xtscal gpe-question matchbox-applet-inputmanager xmodmap xdpyinfo xserver-common ipaq-sleep"
11 SRC_URI += "file://matchbox-session \
12 file://disable-composite.xsettings"
14 PR = "r0"
16 #apply a patch to set the fontsize for bigdpi (200+) devices to 5
17 SRC_URI_append_hx4700 = " file://highdpifontfix.patch"
18 SRC_URI_append_spitz = " file://highdpifontfix.patch"
19 SRC_URI_append_akita = " file://highdpifontfix.patch"
20 SRC_URI_append_c7x0 = " file://highdpifontfix.patch"
21 SRC_URI_append_nokia770 = " file://highdpifontfix.patch"
24 do_configure_append_angstrom() {
25 sed -i s:Default:Clearlooks:g X11/xsettings.default
26 sed -i s:Industrial:Clearlooks:g X11/xsettings.default
29 export CURSOR_HIDE = '${@base_contains("MACHINE_FEATURES","touchscreen","-use_cursor no","-use_cursor yes",d)}'
31 do_install_append() {
32 install -d ${D}${sysconfdir}/gpe/xsettings-default.d
33 if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
34 echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
36 install -d ${D}${sysconfdir}/matchbox
37 install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
38 printf "exec matchbox-window-manager ${CURSOR_HIDE} \$@ \n" >> ${D}${sysconfdir}/matchbox/session
41 install -d ${D}${sysconfdir}/gpe/xsettings-default.d
42 install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
44 mv ${D}${bindir}/gpe-logout.sh ${D}${bindir}/gpe-logout.sh.matchbox
47 pkg_postinst_${PN}() {
48 update-alternatives --install ${bindir}/gpe-logout.sh gpe-logout.sh ${bindir}/gpe-logout.sh.matchbox 10
51 pkg_postrm_${PN}() {
52 update-alternatives --remove gpe-logout.sh ${bindir}/gpe-logout.sh.matchbox
55 # This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
56 PACKAGE_ARCH = "${MACHINE_ARCH}"
58 SRC_URI[md5sum] = "af6941561f0ef676b4536531cd4c40bf"
59 SRC_URI[sha256sum] = "f0cc9809776f77649287e88455657d47e804b11296c0f9f503ea0b1603b2e377"