1 # ECJ as a bootstrap compiler is a drop
-in replacement
for Sun's javac. It offers no more
2 #
and no less features.
4 # This recipe uses the jar created by libecj
-bootstrap.
6 DESCRIPTION
= "JDT Core Batch Compiler - Bootstrap variant"
7 HOMEPAGE
= "http://www.eclipse.org/"
12 DEPENDS
= "libecj-bootstrap virtual/java-native"
14 PROVIDES
= "virtual/javac-native"
16 SRC_URI
= "file://ecj.in"
22 JAR
= "ecj-bootstrap.jar"
24 NATIVE_INSTALL_WORKS
= "1"
29 # Create the start script
30 echo
"#!/bin/sh" > ecj
-bootstrap
31 echo
"ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj
-bootstrap
32 echo
"RUNTIME=java" >> ecj
-bootstrap
33 cat ecj.in
>> ecj
-bootstrap
37 install
-d $
{D
}$
{bindir
}
38 install
-m
755 $
{S
}/ecj
-bootstrap $
{D
}$
{bindir
}
39 install
-m
755 $
{S
}/ecj
-bootstrap $
{D
}$
{bindir
}/javac