systemd: Enable pam if present in DISTRO_FEATURES
[openembedded.git] / recipes / totem / totem_2.30.0.bb
blob5f869a457dcf19eb2bae31799d21af6ee6d29d2d
1 # totem OE build file
2 # Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 DESCRIPTION = "A GTK2 based media player"
6 HOMEPAGE = "http://www.gnome.org/projects/totem/"
7 LICENSE = "GPL"
9 DEPENDS = " nautilus tracker gnome-doc-utils libunique libgdata totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
10 RDEPENDS_${PN} += "iso-codes"
11 RRECOMMENDS_${PN} += "gst-plugin-playbin \
12 gst-plugin-gconfelements \
13 gst-plugin-decodebin \
14 gst-plugin-decodebin2 \
15 gst-ffmpeg \
16 gst-plugin-audioresample \
17 gst-plugin-ximagesink \
18 gst-plugin-xvimagesink \
19 gst-plugin-alsa \
20 gst-plugin-avi \
21 gst-plugin-ffmpegcolorspace \
22 gst-plugin-flv \
23 gst-plugin-nuvdemux \
24 gst-plugin-videoscale \
25 gst-plugin-a52dec \
26 gst-plugin-mpegaudioparse \
27 gst-plugin-ossaudio \
28 gst-plugin-pulse \
29 gst-plugin-autodetect \
30 totem-plugin-thumbnail totem-plugin-dbus "
32 inherit gnome
34 PR = "r1"
36 SRC_URI += "file://gst-detect.diff"
38 SRC_URI[archive.md5sum] = "ecee18e876f6adf5845f71ace87549ca"
39 SRC_URI[archive.sha256sum] = "9d8edd266bd2546e4c8034de1196b79855e24a3634d05cc4f8a07fd3edc7b1af"
41 EXTRA_OECONF=" --enable-shared \
42 --disable-static \
43 --disable-schemas-install \
44 --disable-iso-codes \
45 --disable-debug \
46 --enable-browser-plugins \
47 --disable-run-in-source-tree \
48 --disable-vala \
49 --enable-python \
50 --with-dbus \
53 do_configure_prepend() {
54 sed -i -e s:help::g ${S}/Makefile.am
55 sed -i \
56 -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \
57 -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
58 -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \
59 -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \
60 -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
61 -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
62 -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
63 -e 's:PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION":PYTHON_CFLAGS="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
64 ${S}/configure.in
67 PACKAGES_DYNAMIC += " totem-plugin-* "
69 python populate_packages_prepend () {
70 totem_libdir = bb.data.expand('${libdir}/totem/plugins/', d)
72 do_split_packages(d, totem_libdir, '^(.*)', 'totem-plugin-%s', 'totem plugin for %s', allow_dirs=True, extra_depends='')
75 FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications \
78 RDEPENDS_totem-plugin-iplayer_append = "python-pygtk gst-plugin-flv"
79 RDEPENDS_totem-plugin-youtube_append = "python-pygtk gnome-vfs-plugin-http gst-plugin-gnomevfs gst-plugin-flv"
82 PACKAGES =+ "totem-nautilus-extension totem-browser-plugin-dbg totem-browser-plugin"
84 FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
85 FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
86 FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
87 FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"
89 FILES_totem-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"