systemd: Enable pam if present in DISTRO_FEATURES
[openembedded.git] / recipes / phalanx / phalanx_22.bb
blobb456a3035a6bbca90d118e5d626b0fc93056ec9f
1 DESCRIPTION = "Phalanx is a chess playing engine."
2 SECTION = "opie/libs"
3 PRIORITY = "optional"
4 PR = "r5"
5 LICENSE = "GPL"
6 SRC_URI = "http://ftp.debian.org/debian/pool/main/p/phalanx/phalanx_22+d051004.orig.tar.gz \
7 file://capabilities \
8 file://description"
9 S = "${WORKDIR}/Phalanx-XXII/"
11 do_compile() {
12 oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
15 do_install() {
16 install -d ${D}${palmtopdir}/chess/engines/Phalanx
17 install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
18 install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
19 >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
20 >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
21 install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
22 install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
25 FILES_${PN} = "${palmtopdir}/chess"
26 FILES_${PN}-dbg += "${palmtopdir}/chess/engines/Phalanx/.debug"
27 SRC_URI[md5sum] = "24657c063f5fda57e70130483bd45cd0"
28 SRC_URI[sha256sum] = "1ec5e8e5f71e199963796462086a6e9a0d8856b7fd4b83324a30a35c25677082"