5 EXTRA_OECONF
= "--with-libtiff --disable-xkb --disable-glibtest --enable-display-migration gio_can_sniff=yes"
7 PACKAGES_DYNAMIC
= "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
9 python populate_packages_prepend
() {
12 prologue
= bb.
data.getVar
("postinst_prologue", d
, 1)
14 gtk_libdir
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/$
{LIBV
}'
, d
)
15 loaders_root
= os.path.join
(gtk_libdir
, 'loaders'
)
16 immodules_root
= os.path.join
(gtk_libdir
, 'immodules'
)
17 printmodules_root
= os.path.join
(gtk_libdir
, 'printbackends'
);
18 modules_root
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/modules
/'
,d
)
20 do_split_packages
(d
, loaders_root
, '^libpixbufloader
-(.
*)\.so$'
, 'gdk
-pixbuf
-loader
-%s'
, 'GDK pixbuf loader
for %s'
, prologue
+ 'gdk
-pixbuf
-query
-loaders
> /etc
/gtk
-2.0/gdk
-pixbuf.loaders'
, extra_depends
=''
)
21 do_split_packages
(d
, immodules_root
, '^im
-(.
*)\.so$'
, 'gtk
-immodule
-%s'
, 'GTK
input module
for %s'
, prologue
+ 'gtk
-query
-immodules
-2.0 > /etc
/gtk
-2.0/gtk.immodules'
, extra_depends
=''
)
22 do_split_packages
(d
, printmodules_root
, '^libprintbackend
-(.
*)\.so$'
, 'gtk
-printbackend
-%s'
, 'GTK printbackend module
for %s'
, extra_depends
=''
)
23 do_split_packages
(d
, modules_root
, '^lib
(.
*)\.so$'
, 'gtk
-module
-%s'
, 'GTK module
for %s'
, extra_depends
=''
)
25 if (bb.
data.getVar
('DEBIAN_NAMES'
, d
, 1)):
26 bb.
data.setVar
('PKG_$
{PN
}'
, 'libgtk
-2.0'
, d
)
29 # gail is part of gtk
+ since gtk
+-2.13.0 (targetting
>=GNOME
2.23):
30 PROVIDES
= "virtual/gail"
31 RPROVIDES_$
{PN
} = "libgailutil18"
32 RCONFLICTS_$
{PN
} = "libgailutil18"
33 RREPLACES_$
{PN
} = "libgailutil18"
34 RPROVIDES_$
{PN
}-dev
= "libgailutil-dev"
35 RCONFLICTS_$
{PN
}-dev
= "libgailutil-dev"
36 RREPLACES_$
{PN
}-dev
= "libgailutil-dev"
37 RPROVIDES_$
{PN
}-doc
= "libgailutil-doc"
38 RCONFLICTS_$
{PN
}-doc
= "libgailutil-doc"
39 RREPLACES_$
{PN
}-doc
= "libgailutil-doc"
40 RPROVIDES_$
{PN
}-dbg
= "libgailutil-dbg"
41 RCONFLICTS_$
{PN
}-dbg
= "libgailutil-dbg"
42 RREPLACES_$
{PN
}-dbg
= "libgailutil-dbg"
43 # FIXME
: replace locales as well
46 SRC_URI
[gtk.md5sum
] = "416412b336d9f3b6b78ca887395d1726"
47 SRC_URI
[gtk.sha256sum
] = "18e0f9792028e6cc5108447678f17d396f9a2cdfec1e6ab5dca98cb844f954af"