systemd: Enable pam if present in DISTRO_FEATURES
[openembedded.git] / recipes / adns / adns_1.0.bb
blob96e47811e2f512cdfc94a6b5d4548b423719dc70
1 DESCRIPTION = "An advanced alternative, asynchronous resolver."
2 SECTION = "console/network"
3 LICENSE="GPL"
5 SRC_URI = "ftp://ftp.gnu.org/gnu/adns/adns-${PV}.tar.gz \
6 file://configure.patch \
7 file://fixparsedomainflags.patch"
9 inherit autotools
11 acpaths = ""
12 do_configure_prepend () {
13 if ! test -e acinclude.m4; then
14 cp aclocal.m4 acinclude.m4
18 do_stage () {
19 install -m 0644 ${S}/src/adns.h ${STAGING_INCDIR}/
20 oe_libinstall -so -C dynamic libadns ${STAGING_LIBDIR}/
21 oe_libinstall -a -C src libadns ${STAGING_LIBDIR}/
24 do_install () {
25 install -d ${D}${prefix} ${D}${exec_prefix} \
26 ${D}${bindir} ${D}${libdir} ${D}${includedir}
27 oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
28 'bin_dir=${D}${bindir}' 'lib_dir=${D}${libdir}' \
29 'include_dir=${D}${includedir}' install
32 SRC_URI[md5sum] = "af4411ee10875b96c0d61f903018f438"
33 SRC_URI[sha256sum] = "bed27a4ec5b71acc08333368e842a1248e83328018b582caf644985539967c5d"